4 Coisas que Você Precisa Saber sobre o WordPress 5.0

A última versão do WordPress foi lançada no dia 19 de Novembro, sendo esta a versão 5 do mais usado CMS do mundo. O WordPress 5.0 trouxe várias melhorias, novos recursos e redefiniu alguns conceitos de utilização de ferramentas dentro do gerenciador de conteúdo, como por exemplo o novo editor Gutenberg que mudou drasticamente a interface de publicação de posts e páginas, e como ele funciona.

Sempre é bom lembrar da importância de manter seu WordPress atualizado para evitar vulnerabilidades de segurança, manter o desempenho do seu WordPress e também para ter acesso aos últimos recursos disponibilizados.

Neste artigo vamos ver 4 coisas que você precisa saber sobre o WordPress 5.0 antes de atualizar sua instalação. Tenha em mente que saber o que está por vir pode evitar surpresas desagradáveis após a atualização.

 

1 – Você precisa aprender a usar o editor Gutenberg

O editor Gutenberg é o novo construtor de posts e páginas que mudou completamente a interface de edição do WordPress. Este novo editor permite que você arraste e solte os blocos de conteúdos para a construção da sua publicação, seja uma página ou um post. O editor Gutenberg será o novo padrão em substituição ao editor clássico do WordPress que vem sendo utilizado praticamente desde o lançamento do CMS.

É recomendado que você experimente o editor Gutenberg em um ambiente de testes antes de atualizar seu WordPress, para decidir se gostará da maneira como ele funciona. Como é uma mudança bastante drástica, provavelmente haverá um tempo de adaptação até você se acostumar a usar ele para criar suas publicações.

Também não posso esquecer de citar, caso você utilize algum plugin ou extensão no WordPress que enriquece a interface de publicação como por exemplo o WPBakery Page Builder para WordPress, haverá a necessidade de você revisar a compatibilidade destes plugis com a nova interface Gutenberg.

2 – Compatibilidade dos temas e plugins com o Gutenberg

No processo de criação e lançamento do WordPress 5.0, muitos desenvolvedores de temas e plugins tentaram oferecer atualizações compatíveis com a nova versão. No entanto, nem todas as ferramentas existentes estarão preparadas ou serão compatíveis. Isso significa que há uma chance de que o Gutenberg não esteja plenamente compatível com o tema e plugins do seu WordPress.

Vale lembrar que o time de desenvolvimendo do Gutenberg sempre tomou medidas para proteger a formatação de conteúdo e a interoperabilidade com os atuais plugins construtores de blocos. Como esta é uma atualização muito grande, recomendo a abordagem “melhor prevenir do que remediar”. Verifique os seus plugins e temas se estão plenamente compatíveis com a versão 5.0 antes de realizar a atualização (e sempre faça um backup antes 😉 )

3 – Você pode manter o editor clássico

Se você não gostar do novo editor, ou por puro costume (como eu) quiser manter o editor clássico, não se sinta frutrado. É possível manter o editor clássico no WordPress 5.0 mas será necessário desativar o Gutenberg e instalar o plugin de editor clássico.

Primeiro, faça backup do seu WordPress (segurança nunca é demais) e em seguida, no painel de administração do seu site visite Plugins > Adicionar Novo e pesquise “classic editor” .

Instale e ative o plugin, isso redirecionará você para a página de plugins e a partir daí você poderá abrir as configurações do editor clássico:

Se você quiser desativar completamente o editor do Gutenberg, escolha Substituir o editor de bloco com o editor Clássico . Se você quiser usar o editor Gutenberg com o editor Classic como opção, por outro lado, selecione Usar o editor de bloco por padrão e inclua links opcionais de volta ao editor Clássico .

Claro, existem são algumas desvantagens para a desativação do editor Gutenberg. Muitos acreditam que o editor de Gutenberg se tornará o futuro do WordPress. Por não usá-lo, você pode estar perdendo oportunidades para dar ao seu site uma aparência mais moderna.

Além, com o tempo os desenvolvedores de temas podem começar a adotar o Gutenberg como padrão, deixando sites que não o utilizam desatualizados. Claro que você poderá ir utilizando o editor clássico até se familiarizar melhor com o novo editor.

4 – É vital atualizar seu site para Gutenberg assim que possível

Estas dicas podem parecer desencorajar você a atualizar seu WordPress para a versão 5.0. Na verdade, você pode estar se perguntando se simplesmente pode ignorar competamente esta atualização. Não.

Juntamente com os novos recursos, as atualizações do WordPress adicionam novos recursos de segurança e outros elementos importantes ao seu site. Por exemplo, essa atualização central específica também está ajudando a tornar o WordPress compatível com a versão mais recente do PHP. Manter-se atualizado é crucial para manter seu site seguro e garantir que ele seja executado sem problemas.

Contanto que você tome algumas precauções, como testar o Gutenberg e ter um backup recente, os riscos de não atualizar o WordPress compensarão os riscos de atualizá-lo.

Conclusão

O WordPress 5.0 será uma grande mudança em relação à versão atual da plataforma, e é importante estar ciente do que está por vir. No entanto, desde que você tome as precauções descritas neste artigo antes de atualizar, você deverá ter poucos ou nenhum problema como resultado das alterações.

Algumas coisas a se ter em mente sobre o WordPress 5.0 incluem:

  1. Você precisará aprender a usar o editor de Gutenberg, mais cedo ou mais tarde.
  2. Seu tema e plugins podem não ser compatíveis com o Gutenberg, o que significa que você precisará realizar alguns testes.
  3. Você pode manter a interface existente, se desejar, usando o plug-in do Editor Clássico.
  4. Você não deve evitar a atualização, já que as atualizações do WordPress são vitais para segurança e desempenho.

Espero que este artigo ajude a você na transição sem problemas para esta nova atualização. Avante!

Você pode gostar...